Problema con Addons

Peluca

New member
Hola que tal, soy nuevo en el juego desde la plataforma de PC y a la hora de agregar addons ya sea manualmente o con ayuda del programa llamado Minion me he encontrado con que no puedo acceder a su configuración. Dejare imágenes para ilustrarlos.
Primero que nada para que los addons me funcionen tengo que marcar la casilla que se encuentra en la parte superior que dice "Allow out of date add-ons" ya que por el contrario no me reconoce ningún addon.
addons1.png
Una ves hecho esto, me aparecen en blanco con una breve descripción.
Screenshot_2.png
Luego cuando intento abrir la ventana para poder configurar los addons me sale el siguiente error
Screenshot_3.png
bad argument #1 to 'ipairs' (table/struct expected, got nil)
stack traceback:
[C]: in function 'ipairs'
EsoUI/PregameAndIngame/ZO_Options/Keyboard/ZO_Options_Keyboard.lua:162: in function 'ZO_KeyboardOptions:panelRequiresDeferredLoading'
|caaaaaa<Locals> self = [table:1]{currentPanelId = 103, currentPanel = 101, isGamepadOptions = F}, panelId = 101 </Locals>|r
EsoUI/PregameAndIngame/ZO_Options/Keyboard/ZO_Options_Keyboard.lua:146: in function 'ZO_KeyboardOptions:ChangePanels'
|caaaaaa<Locals> self = [table:1], panelId = 101, panelName = "Addons", readyToShowPanel = T </Locals>|r
user:/AddOns/MiniMap/LibAddonMenu-2.0/LibAddonMenu-2.0.lua:907: in function 'panelData.callback'
EsoUI/Common/ZO_GameMenu/ZO_GameMenu.lua:52: in function 'TreeEntryOnSelected'
|caaaaaa<Locals> control = ud, data = [table:2]{id = 101, categoryName = "Settings", name = "Addons"}, selected = T, reselectingDuringRebuild = F </Locals>|r
EsoUI/Libraries/ZO_Tree/ZO_Tree.lua:705: in function 'ZO_TreeNode:OnSelected'
|caaaaaa<Locals> self = [table:3]{childrenCurrentHeight = 0, childrenHeight = 0, openPercentage = 0, enabled = T, selected = F, childSpacing = 8, selectSound = "Click_TreeSubcategory", open = F, childIndent = 30}, reselectingDuringRebuild = F </Locals>|r
EsoUI/Libraries/ZO_Tree/ZO_Tree.lua:411: in function 'ZO_Tree:SelectNode'
|caaaaaa<Locals> self = [table:4]{exclusive = T, defaultIndent = 30, suspendAnimations = F, enabled = T, autoSelectChildOnNodeOpen = F, openAnimationDurationMS = 300, width = 285, defaultSpacing = 8}, treeNode = [table:3], reselectingDuringRebuild = F, bringParentIntoView = F </Locals>|r
EsoUI/Libraries/ZO_Tree/ZO_Tree.lua:888: in function 'ZO_TreeEntry_OnMouseUp'
|caaaaaa<Locals> self = ud, upInside = T, NOT_REBUILDING = F, DONT_BRING_PARENT_INTO_VIEW = F </Locals>|r
ZO_CollectionsBook_TopLevelCategoriesScrollChildZO_CollectionsBook_SubCategory1_MouseUp:3: in function '(main chunk)'
|caaaaaa<Locals> self = ud, button = 1, upInside = T, ctrl = F, alt = F, shift = F, command = F </Locals>|r

Y en la ultima opción no aparece nada como puede verse en la imagen
Screenshot_4.png

Ojala puedan ayudarme a lograr solucionar el problema, estaré al tanto por cualquier dato que quieran saber. Saludos.
 
Forohardware.com

Kwisatz

Super Moderator
Miembro del equipo
Los addons no siempre necesitan actualizaciones tan frecuentes como tiene el juego, personalmente, uso algún que otro addon que llevará sin actualizar desde el 2014 y sigue funcionando sin dar ningún problema, siempre y cuando le diga al juego que cargue los addons cuya versión sea anterior a la del juego: autorizar la carga de addons obsoletos es precisamente la función de la casilla "allow out of date add-ons".

En la segunda pantalla, te aparecen en blanco porque ya los has autorizado y han cargado. Sin embargo, ves que aún te salen algunas líneas en rojo: eso te muestra elementos que no tienes o que no has cargado, y que son necesarios para el funcionamiento de ciertos addons (dependency). Tienes que buscar esas librerías y cargarlas como cualquier otro addon independiente.

Después de hacer eso, puede que ya no te aparezcan los mensajes de error y que te funcione la interfaz como es debido.
Pero no hay que olvidar que, si autorizas addons no actualizados para la última versión del juego, tienes que asumir que existe el riesgo de que te den problemas o que hayan dejado de funcionar.
Te pertenece a ti valorar el grado de molestia que te provocará tal o tal addon obsoleto.
 
Forohardware.com

Peluca

New member
Los addons no siempre necesitan actualizaciones tan frecuentes como tiene el juego, personalmente, uso algún que otro addon que llevará sin actualizar desde el 2014 y sigue funcionando sin dar ningún problema, siempre y cuando le diga al juego que cargue los addons cuya versión sea anterior a la del juego: autorizar la carga de addons obsoletos es precisamente la función de la casilla "allow out of date add-ons".

En la segunda pantalla, te aparecen en blanco porque ya los has autorizado y han cargado. Sin embargo, ves que aún te salen algunas líneas en rojo: eso te muestra elementos que no tienes o que no has cargado, y que son necesarios para el funcionamiento de ciertos addons (dependency). Tienes que buscar esas librerías y cargarlas como cualquier otro addon independiente.

Después de hacer eso, puede que ya no te aparezcan los mensajes de error y que te funcione la interfaz como es debido.
Pero no hay que olvidar que, si autorizas addons no actualizados para la última versión del juego, tienes que asumir que existe el riesgo de que te den problemas o que hayan dejado de funcionar.
Te pertenece a ti valorar el grado de molestia que te provocará tal o tal addon obsoleto.
Muchísimas gracias por responder, entiendo lo que dijiste. Buscare los elementos faltantes para ver si se soluciona. Muchas gracias nuevamente, saludos.
 
Forohardware.com
Forohardware.com
Arriba